Thames water points missing from map

Incident Report for WaterWatch

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 11:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 22, 2026 - 20:44 UTC

Update

We are currently having issues accessing the data from thames water. We appreciate this is frustrating however this issue is currently out of our hands as we wait for the system to resolve. In the meantime, the official thames water map is working and can be visited at thameswater.co.uk/edm-map
Posted Jun 22, 2026 - 19:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 22, 2026 - 19:01 UTC

Investigating

We are currently investigating this issue.
Posted Jun 22, 2026 - 18:49 UTC
This incident affected: Website and Data Sources (Thames Water).