Slow Loading Site

Incident Report for WaterWatch

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 19:05 UTC

Identified

The issue has been found, relating to our 3rd party compute provider. Due to a site outage, we have reduced capacity. We are waiting for further instructions and will continue to optimize and regulate the site as much as possible to keep as many of you flowing through the system smoothly
Posted Jun 25, 2026 - 16:50 UTC

Investigating

We're aware some pages on the site are loading slower than we'd like. Rest assured, we're aware and actively looking into it. Thanks for your patience. In the meantime, you can wait or try your request at a quieter time.
Posted Jun 25, 2026 - 15:42 UTC
This incident affected: Website.