Essential Maintenance

Incident Report for WaterWatch

Resolved

We've done it!!! You should see everything running, at faster speeds than before
Posted Aug 08, 2026 - 21:38 UTC

Investigating

We're conducting maintenance to speed things up. After all, what's the point of watching rivers if we can't tell you quickly?

Things may be down for a couple of minutes, just grab a cuppa and hit refresh. Email alerts will continue to remain operational
Posted Aug 08, 2026 - 21:32 UTC
This incident affected: Website.