Website Outage: Data Issue

Incident Report for WaterWatch

Resolved

The issue has been resolved. Thanks for your patience
Posted May 18, 2026 - 14:43 UTC

Identified

The issue has reoccurred. We're still working on it
Posted May 18, 2026 - 07:13 UTC

Monitoring

A fix has been applied and improvements are being monitored
Posted May 18, 2026 - 05:27 UTC

Update

We're continuing to work on a fix
Posted May 17, 2026 - 21:54 UTC

Identified

We've identified an issue with a 3rd party supplier. At this point we predict the site will remain offline until 08:00 GMT as we wait for further instructions from the supplier
Posted May 17, 2026 - 19:58 UTC

Investigating

We are currently experiencing issues with the site.
Posted May 17, 2026 - 18:27 UTC
This incident affected: Website and Data Sources (Thames Water).